Instance with the same key already exists.
Issue
Your want to create a new transport request. This creation is failing with the error message “Instance with the same key already exists.”.
Root cause
We are shadowing/storing all transport request details in table /XALM/D_CC5_REQ of your managing system. There are some keys, indexes and checks implemented. These keys/indexes/checks are ensuring that a transport request can be assigned only once to ticket.
Maybe in the past there was something going wrong creating a entry with a system but without a transport request id. This entry might now block the creation of new entries for the same system because on creation the transport request id is empty/initial and because such an entry is already existing.
Solution
Usually this issue should not occure. If transport request creation is failing, the corresponding datzaset should never be saved to database. However in our own development system it happened and maybe in some customer systems it will happen too.
Please logon into your SAP system (managing system), call SE16, open table /XALM/D_CC5_REQ, earch for entries with empty ID and delete this entry.
If the issue will occure again and again, please contact our support. We will help you to find and fix the root cause.
Since 2025/05 a transport request can be assigned to multiple tickets at the same time but still only once to a certain ticket. Since this change the issue can occure only inside one ticket. An issue with one ticket cannot affect other tickets anymore. The solution described below is still valid but you as customer might not consider the issue as high priority disruption anymore.